You are browsing a version that has not yet been released.

Introduction

The DoctrineORMModule leverages DoctrineModule and integrates Doctrine ORM with Laminas quickly and easily. The following features are intended to work out of the box:

  • Doctrine ORM support
  • Multiple ORM entity managers
  • Multiple DBAL connections
  • Reuse existing PDO connections in DBAL connection

Installation

Run the following to install this library using Composer:

$ composer require doctrine/doctrine-orm-module

Note on PHP 8.0 or later

DoctrineModule provides an integration with laminas-cache, which currently comes with some storage adapters which are not compatible with PHP 8.0 or later. To prevent installation of these unused cache adapters, you will need to add the following to your composer.json file:

1"require": { "doctrine/doctrine-orm-module": "^4.1.0" }, "replace": { "laminas/laminas-cache-storage-adapter-apc": "*", "laminas/laminas-cache-storage-adapter-dba": "*", "laminas/laminas-cache-storage-adapter-memcache": "*", "laminas/laminas-cache-storage-adapter-memcached": "*", "laminas/laminas-cache-storage-adapter-mongodb": "*", "laminas/laminas-cache-storage-adapter-wincache": "*", "laminas/laminas-cache-storage-adapter-xcache": "*", "laminas/laminas-cache-storage-adapter-zend-server": "*" }
2
3
4
5
6
7
8
9
10
11
12
13

Consult the laminas-cache documentation for further information on this issue.