[PHPCR-89] child documents are not translateable? Created: 07/Feb/13  Updated: 18/Apr/13  Resolved: 18/Apr/13

Status: Closed
Project: Doctrine PHPCR
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Major
Reporter: Norbert M Haigermoser Assignee: Lukas Kahwe
Resolution: Cannot Reproduce Votes: 0
Labels: i18n, translation
Environment:

ubuntu 12.04, php 5.3,
installed:
doctrine/common [2.3.x-dev bb0aebb] : Common Library for Doctrine projects
doctrine/dbal [2.3.x-dev fd45c6f] : Database Abstraction Layer
doctrine/phpcr-odm [dev-master 76765d1] : Object-Document-Mapper for PHPCR
jackalope/jackalope [dev-master a8ba9db] : Jackalope PHPCR library
jackalope/jackalope-doctrine-dbal [dev-master d8a81bc] : Jackalope Transport library
phpcr/phpcr [2.1.0-beta8] : PHP Content Repository interfaces
phpcr/phpcr-utils [1.0-beta4] : PHP Content Repository implementation independant utilities
symfony/console [2.2.x-dev v2.2.0-RC1] : Symfony Console Component
symfony/yaml [dev-master f198ac2] : Symfony Yaml Component


Attachments: File index_1.php    

 Description   

I just tried the odm on a testproject. but i have a really strange problem with translations. if i add a document which has children - and then try to add a translation to the children documents - the translation will not be saved .... (i tried the same with the symfony cmf - same result )
code:



 Comments   
Comment by David Buchmann [ 12/Mar/13 ]

hi. can you try to write a test case in TranslationHierarchyTest in the phpcr-odm repository and create a pull request for the failing test? we fixed quite some things around this recently, maybe it is fixed now?

Generated at Thu Jul 24 23:12:09 UTC 2014 using JIRA 6.2.3#6260-sha1:63ef1d6dac3f4f4d7db4c1effd405ba38ccdc558.