Doctrine PHPCR
  1. Doctrine PHPCR
  2. PHPCR-67

Fetching a node beforehand ruins ordering of collections

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Labels:
      None

      Description

      Two documents: Category and Subcategory
      Category has $subcategories as a PHPCRODM\Children

      If Category A has 3 subcategories B1 B2 B3.

      If A's subcategories are fetched we would receive them in the following order: B1 B2 B3.

      Now if however we fetched the B2 node using the DocumentManager at an earlier line and then fetched the subcategories of A, we would receive them in the following order:
      B2 B1 B3

        Activity

        Freddy H. created issue -
        Lukas Kahwe added a comment -

        i tried to reproduce the issue in a test case:
        https://github.com/doctrine/phpcr-odm/commit/7a3f690cd407f5fc75af4ae3d70b4360c5a499c7

        however the test passes. so either the issue is already fixed or i just didn't understand the bug description properly.

        Lukas Kahwe made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=PHPCR-67, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Lukas Kahwe
            Reporter:
            Freddy H.
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: