Uploaded image for project: 'Doctrine PHPCR'
  1. Doctrine PHPCR
  2. PHPCR-58

figure out how to handle dangling weak/path ReferenceOne/Many properties

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None

      Description

      this is a follow-up of
      https://github.com/doctrine/phpcr-odm/pull/116

      the problem is: what happens when a ReferenceOne path or weak reference property points to something non-existing? is the property null? is the currently invalid reference removed on save or kept (which would make sense, in case the node at path appears later). but if it is usually kept, how can we delete it if we want?

        Activity


          People

          • Assignee:
            lsmith Lukas Kahwe
            Reporter:
            dbu David Buchmann
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: