Doctrine MongoDB ODM
  1. Doctrine MongoDB ODM
  2. MODM-78

mappedSuperclass as parent embedded class

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Mapping Drivers, Persister
    • Labels:
      None

      Description

      Hi,

      i have 3 documents : a contact, a professional address and a personal address
      A contact embed the 2 addresses

      The Contact class inherits from an abstract class DomainAbstract
      The 2 addresses classes inherits from an abstract class Address which inherits from DomainAbstract

      • DomainAbstract <- Contact
      • DomainAbstract <- Address <- PersonalAddress, ProfessionalAddress

      DomainAbstract is defined as mappedSuperclass

      Address is defined as mappedSuperclass

      PersonalAddress, ProfessionalAddress are embeddedDocument

      But the fields defined by address are not inherited by embedded PersonalAddress and ProfessionalAddress ( but the fields in domainAbstract are like expected)

      I think, 2 levels of inheritance and embedded document is wrong...

      thx for help

      ps: yaml mapping

        Activity

        julien rollin created issue -
        Jonathan H. Wage added a comment -

        Could you provide a test case or the files you are using to produce the problem?

        Jonathan H. Wage made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=MODM-78, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            julien rollin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: