Doctrine Migrations
  1. Doctrine Migrations
  2. DMIG-9

table "contact_attribute" already exists - with mappedSuperClass

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Labels:
      None

      Description

      I have a class App_Model_Contact_Attribute:

      App_Model_Contact_Attribute:
        type: mappedSuperclass
        inheritanceType: SINGLE_TABLE
        table: contact_attribute
        discriminatorColumn:
          name: type
          type: string
          length: 20
          columnDefinition: "varchar(20) not null"
        discriminatorMap:
            emailAddress: App_Model_Contact_EmailAddress
            twitterAccount: App_Model_Contact_TwitterAccount
        id:
          id:
            type: integer
            columnDefinition: "int unsigned not null auto_increment"
            generator:
              strategy: AUTO
        fields:
          value:
            type: string
            notnull: true
            columnDefinition: "varchar(45)"
        manyToOne:
          contact:
            joinColumn:
              name: contactID
              referencedColumnName: id
              columnDefinition: "int not null unsigned"
            targetEntity: App_Model_Contact
            fetch: EAGER
            cascade: [persist]
      

      and a class App_Model_Contact_EmailAddress and App_Model_Contact_TwitterAccount. Both yml files look similar to this:

      App_Model_Contact_TwitterAccount:
        type: entity
      

      Now, when I want to execute migrations:diff it always fails giving me the message: "Table contact_attribute already exists".

      This probably has to do with the mappedSuperClass declaration in my models.

        Activity

        Sebastian Hoitz created issue -
        Sebastian Hoitz added a comment -

        This bug does not seem to occur anymore.

        Sebastian Hoitz made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=DMIG-9, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            Sebastian Hoitz
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: