Doctrine Migrations
  1. Doctrine Migrations
  2. DMIG-34

Column names not escaped with backticks

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Labels:
      None
    • Environment:
      MySQL & Linux

      Description

      Generated from an Entity with a variable named access_key, with a column name of "key".

      Generated MySQL table constructor fails, name is not escaped with backticks.

        Activity

        Matthew Baggett created issue -
        Benjamin Eberlei added a comment -

        This is not a bug, you have to explicitly force escpaing manually by giving @Column(name="``key`") in your mapping (or xml/yml equivalent).

        Automatic escaping leads to problems, that is why w edont support it.

        Benjamin Eberlei made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Invalid [ 6 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=DMIG-34, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Benjamin Eberlei
            Reporter:
            Matthew Baggett
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: