Doctrine Migrations
  1. Doctrine Migrations
  2. DMIG-20

migrations try to create an index with name "primary" for ManyToMany associations

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Labels:
      None

      Description

      For ManyToMany associations, migrations try to create a unique index on (joinColumn, inverseJoinColumn) having name "primary":

      CREATE UNIQUE INDEX primary ON join_table (joinColumn, inverseJoinColumn);

      Which results in a syntax error on MySQL (primary is also an invalid key name).

        Activity

        arnaud-lb created issue -
        arnaud-lb made changes -
        Field Original Value New Value
        Description For ManyToMany associations, migrations try to create a unique index on (joinColumn, inverseJoinColumn) having name "primary":

        CREATE UNIQUE INDEX primary ON join_table (joinColumn, inverseJoinColumn);
        For ManyToMany associations, migrations try to create a unique index on (joinColumn, inverseJoinColumn) having name "primary":

        CREATE UNIQUE INDEX primary ON join_table (joinColumn, inverseJoinColumn);

        Which results in a syntax error on MySQL (primary is also an invalid key name).
        Karsten Dambekalns added a comment -

        Caused by / related to DBAL-126

        arnaud-lb added a comment -
        arnaud-lb made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=DMIG-20, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            arnaud-lb
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: