Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-71

Method Doctrine\ORM\Tools\Export\Driver\AnnotationExporter::getClassToExtend() does not exist

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-ALPHA2
    • Fix Version/s: 2.0-ALPHA3
    • Component/s: ORM
    • Security Level: All
    • Labels:
      None
    • Environment:
      sfDoctrine2Plugin (currently embedding Doctrine 2.0.0 Alpha 1) used with Symfony 1.3.0 BETA 1
      WampServer, Apache 2.2.11, PHP 5.3.0, MySQL 5.1.36

      Description

      In Doctrine\ORM\Tools\Export\Driver\AnnotationExporter, on line 191 & 197, method getClassToExtend() is called, whereas the actual name of the method is _getClassToExtend().
      It generates a fatal error when using command line tool symfony doctrine:build --all.

        Activity

        Hide
        Florian Klein added a comment -

        I had the same problem with sfDoctrine2Plugin ( http://svn.symfony-project.org/plugins/sfDoctrinePlugin/branches/1.3-2.0 )
        But it seems to be fixed as I can't reproduce the problem with ./symfony doctrine:build --all
        in rev 6639

        Show
        Florian Klein added a comment - I had the same problem with sfDoctrine2Plugin ( http://svn.symfony-project.org/plugins/sfDoctrinePlugin/branches/1.3-2.0 ) But it seems to be fixed as I can't reproduce the problem with ./symfony doctrine:build --all in rev 6639
        Hide
        Simon VANDENDRIESSCHE added a comment -

        Well the fix version is 2.0-ALPHA3, and sfDoctrine2Plugin is now embedding 2.0-ALPHA3 (was ALPHA1 when I submited this bug), so it might be OK. I'll check this out ASAP.

        Show
        Simon VANDENDRIESSCHE added a comment - Well the fix version is 2.0-ALPHA3, and sfDoctrine2Plugin is now embedding 2.0-ALPHA3 (was ALPHA1 when I submited this bug), so it might be OK. I'll check this out ASAP.
        Hide
        Simon VANDENDRIESSCHE added a comment -

        Well I just downloaded the last version of sfDoctrine2Plugin, and the problem is still there.
        Anyway, the method is still called _getClassToExtend(), and lines 191 & 197 are still calling getClassToExtend(), so it should not work I think... Except if it is a kind of magic that PHP allows, and in this case, I don't know about that !

        Show
        Simon VANDENDRIESSCHE added a comment - Well I just downloaded the last version of sfDoctrine2Plugin, and the problem is still there. Anyway, the method is still called _getClassToExtend(), and lines 191 & 197 are still calling getClassToExtend(), so it should not work I think... Except if it is a kind of magic that PHP allows, and in this case, I don't know about that !

          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            Simon VANDENDRIESSCHE
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: