Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-439

Error in CLI utility with YAML files

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-ALPHA4
    • Fix Version/s: 2.0-BETA1
    • Component/s: Tools
    • Security Level: All
    • Labels:
      None
    • Environment:
      Using Doctrine2 with Symfony2 on CentOS.

      Description

      While running the CLI utility via Symfony2's console I received the following error:

      Notice: Undefined offset: 0 in /home/steve/apps/data_warehouse/src/vendor/doctrine/lib/Doctrine/Common/Cli/CliController.php line 234

      The entity file was being created properly but it wouldn't create the table in the database. If I ran with just --entities it would build the entity with no errors but as soon as I added --and-update-schema or changed it to --all I'd get the error. I tested with an XML mapping file and had no issues. But when I ran it with a YAML file I started seeing this.

      Upon investigation it looks like the $args array contained the following values (there may have been more but it was dieing on the last one):
      --0=create
      --1=drop
      --2=update
      --3=complete-update
      --4=re-create
      --5=dump-sql
      --complete-update=1
      --class-dir=

      This was causing $value to be an empty array which allowed it to get passed the check on line 231 of CliController.php. If I changed that line to include an '|| ! count($value)' check it ran fine without any problems that I can see.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Roman S. Borschel
            Reporter:
            Steven Surowiec
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: