Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-2991

[GH-957] makes doctrine less dependent upon the symfony yamp component

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5
    • Component/s: None
    • Security Level: All
    • Labels:
      None

      Description

      This issue is created automatically through a Github pull request on behalf of thealjey:

      Url: https://github.com/doctrine/doctrine2/pull/957

      Message:

      This is the last place in the framework where the class is just too tightly coupled with the symfony yaml component, that the yaml parser alone cannot be overridden without overriding an entire class.
      I simply brought it in accordance with "Doctrine\ORM\Mapping\Driver\YamlDriver" where a separate method called loadMappingFile exists to parse the mapping file.

        Activity

        Hide
        Doctrine Bot added a comment -

        A related Github Pull-Request [GH-957] was closed:
        https://github.com/doctrine/doctrine2/pull/957

        Show
        Doctrine Bot added a comment - A related Github Pull-Request [GH-957] was closed: https://github.com/doctrine/doctrine2/pull/957

          People

          • Assignee:
            Benjamin Eberlei
            Reporter:
            Doctrine Bot
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: