Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-2734

Composer Broken dependency on dev-master

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: Git Master
    • Fix Version/s: None
    • Component/s: ORM
    • Security Level: All
    • Labels:
      None
    • Environment:
      Ubuntu 12.04 Php 5.4 composer

      Description

      When runing composer with doctrine/orm on dev-master I got the following error

      Your requirements could not be resolved to an installable set of packages.

      Problem 1

      • Installation request for doctrine/orm dev-master -> satisfiable by doctrine/orm[dev-master].
      • doctrine/orm dev-master requires doctrine/dbal >=2.5-dev,<2.6-dev -> no matching package found.
        Problem 2
      • doctrine/orm dev-master requires doctrine/dbal >=2.5-dev,<2.6-dev -> no matching package found.
      • symfony/framework-standard-edition 2.3.x-dev requires doctrine/orm dev-master -> satisfiable by doctrine/orm[dev-master].
      • Installation request for symfony/framework-standard-edition 2.3.x-dev -> satisfiable by symfony/framework-standard-edition[2.3.x-dev].

      Potential causes:

      Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

        Activity

        Hide
        Christophe Coevoet added a comment -

        I suspect you have your minimum stability set to "stable", which means that the dev versions of DBAL and Common cannot be used to fulfill the requirement (while it is exactly what is needed).

        you have 3 solutions:

        • change your minimum stability when you are using unstable libraries
        • whitelist the dev version of DBAL and Common in your root composer.json (by adding a requirement with a @dev flag)
        • use stable versions of Doctrine (i.e. 2.4) instead of using the master branch
        Show
        Christophe Coevoet added a comment - I suspect you have your minimum stability set to "stable", which means that the dev versions of DBAL and Common cannot be used to fulfill the requirement (while it is exactly what is needed). you have 3 solutions: change your minimum stability when you are using unstable libraries whitelist the dev version of DBAL and Common in your root composer.json (by adding a requirement with a @dev flag) use stable versions of Doctrine (i.e. 2.4) instead of using the master branch
        Hide
        Christophe Coevoet added a comment -

        And as a side note, composer is giving you a link to the explanation about the minimum stability setting in its output

        Show
        Christophe Coevoet added a comment - And as a side note, composer is giving you a link to the explanation about the minimum stability setting in its output
        Hide
        Nicolas Macherey added a comment -

        Sure that's true indeed...
        Then the problem is more related to Symfony2's doctrine bundles that are incompatible with the 2.5@dev. Even if I set minimum stability to "dev" or if I include the required dependencies manually in the root composer.json.

        Thanks

        Here is the output I may still forgot something:

        Problem 1

        • doctrine/migrations dev-master requires doctrine/dbal >=2.0,<2.5.x-dev -> satisfiable by doctrine/dbal[v2.4.0, 2.0.x-dev, 2.1.5, 2.1.6, 2.1.7, 2.1.x-dev, 2.2.0, 2.2.0-BETA2, 2.2.0-RC1, 2.2.0-RC2, 2.2.0-RC3, 2.2.0-beta1, 2.2.1, 2.2.2, 2.2.x-dev, 2.3.0, 2.3.0-BETA1, 2.3.0-RC1, 2.3.0-RC2, 2.3.0-RC3, 2.3.0-RC4, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.x-dev, 2.4.0-BETA1, 2.4.0-BETA2, 2.4.0-RC1, 2.4.0-RC2, 2.4.x-dev].
        • doctrine/migrations dev-master requires doctrine/dbal >=2.0,<2.5.x-dev -> satisfiable by doctrine/dbal[v2.4.0, 2.0.x-dev, 2.1.5, 2.1.6, 2.1.7, 2.1.x-dev, 2.2.0, 2.2.0-BETA2, 2.2.0-RC1, 2.2.0-RC2, 2.2.0-RC3, 2.2.0-beta1, 2.2.1, 2.2.2, 2.2.x-dev, 2.3.0, 2.3.0-BETA1, 2.3.0-RC1, 2.3.0-RC2, 2.3.0-RC3, 2.3.0-RC4, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.x-dev, 2.4.0-BETA1, 2.4.0-BETA2, 2.4.0-RC1, 2.4.0-RC2, 2.4.x-dev].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.0].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.x-dev].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.0].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.0-BETA1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.0-RC1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.0-RC2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.0-RC3].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.0-RC4].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.3].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.4].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.3.x-dev].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.4.0-BETA1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.4.0-BETA2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.4.0-RC1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.4.0-RC2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.4.x-dev].
        • Can only install one of: doctrine/dbal[v2.4.0, 2.5.x-dev].
        • Can only install one of: doctrine/dbal[2.5.x-dev, v2.4.0].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.0.x-dev].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.1.5].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.1.6].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.1.7].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.1.x-dev].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.0-BETA2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.0-RC1].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.0-RC2].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.0-RC3].
        • Can only install one of: doctrine/dbal[2.5.x-dev, 2.2.0-beta1].
        • doctrine/orm dev-master requires doctrine/dbal >=2.5-dev,<2.6-dev -> satisfiable by doctrine/dbal[2.5.x-dev].
        • Installation request for doctrine/orm dev-master -> satisfiable by doctrine/orm[dev-master].
        • Installation request for doctrine/migrations dev-master -> satisfiable by doctrine/migrations[dev-master].
        Show
        Nicolas Macherey added a comment - Sure that's true indeed... Then the problem is more related to Symfony2's doctrine bundles that are incompatible with the 2.5@dev. Even if I set minimum stability to "dev" or if I include the required dependencies manually in the root composer.json. Thanks Here is the output I may still forgot something: Problem 1 doctrine/migrations dev-master requires doctrine/dbal >=2.0,<2.5.x-dev -> satisfiable by doctrine/dbal [v2.4.0, 2.0.x-dev, 2.1.5, 2.1.6, 2.1.7, 2.1.x-dev, 2.2.0, 2.2.0-BETA2, 2.2.0-RC1, 2.2.0-RC2, 2.2.0-RC3, 2.2.0-beta1, 2.2.1, 2.2.2, 2.2.x-dev, 2.3.0, 2.3.0-BETA1, 2.3.0-RC1, 2.3.0-RC2, 2.3.0-RC3, 2.3.0-RC4, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.x-dev, 2.4.0-BETA1, 2.4.0-BETA2, 2.4.0-RC1, 2.4.0-RC2, 2.4.x-dev] . doctrine/migrations dev-master requires doctrine/dbal >=2.0,<2.5.x-dev -> satisfiable by doctrine/dbal [v2.4.0, 2.0.x-dev, 2.1.5, 2.1.6, 2.1.7, 2.1.x-dev, 2.2.0, 2.2.0-BETA2, 2.2.0-RC1, 2.2.0-RC2, 2.2.0-RC3, 2.2.0-beta1, 2.2.1, 2.2.2, 2.2.x-dev, 2.3.0, 2.3.0-BETA1, 2.3.0-RC1, 2.3.0-RC2, 2.3.0-RC3, 2.3.0-RC4, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.x-dev, 2.4.0-BETA1, 2.4.0-BETA2, 2.4.0-RC1, 2.4.0-RC2, 2.4.x-dev] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.0] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.x-dev] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.0] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.0-BETA1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.0-RC1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.0-RC2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.0-RC3] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.0-RC4] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.3] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.4] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.3.x-dev] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.4.0-BETA1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.4.0-BETA2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.4.0-RC1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.4.0-RC2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.4.x-dev] . Can only install one of: doctrine/dbal [v2.4.0, 2.5.x-dev] . Can only install one of: doctrine/dbal [2.5.x-dev, v2.4.0] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.0.x-dev] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.1.5] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.1.6] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.1.7] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.1.x-dev] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.0-BETA2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.0-RC1] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.0-RC2] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.0-RC3] . Can only install one of: doctrine/dbal [2.5.x-dev, 2.2.0-beta1] . doctrine/orm dev-master requires doctrine/dbal >=2.5-dev,<2.6-dev -> satisfiable by doctrine/dbal [2.5.x-dev] . Installation request for doctrine/orm dev-master -> satisfiable by doctrine/orm [dev-master] . Installation request for doctrine/migrations dev-master -> satisfiable by doctrine/migrations [dev-master] .
        Hide
        Marco Pivetta added a comment - - edited

        Dev versions are not supposed to be compatible with packages from the symfony scenario unless they require it. You can alias versions in composer.json to force installation

        Show
        Marco Pivetta added a comment - - edited Dev versions are not supposed to be compatible with packages from the symfony scenario unless they require it. You can alias versions in composer.json to force installation

          People

          • Assignee:
            Marco Pivetta
            Reporter:
            Nicolas Macherey
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: