Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-2309

Invalid behaviour to flush only one entity

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2, 2.3
    • Fix Version/s: None
    • Component/s: ORM
    • Labels:
      None

      Description

      Current implementation of $em->flush($entity):

      • does not flush entity scheduled for delete
      • flush all entities scheduled for insert

      http://www.doctrine-project.org/jira/browse/DDC-720

        Issue Links

          Activity

          Benjamin Eberlei added a comment -

          The second point is documented, the first point i don't understand, can you elaborate?

          Benjamin Eberlei added a comment -

          Duplicate of DDC-2267


            People

            • Assignee:
              Benjamin Eberlei
              Reporter:
              Martin Hasoň
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: