Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-2186

PreFlushEventArgs not passed by ClassMetadataInfo::invokeLifecycleCallbacks()

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.4
    • Component/s: Mapping Drivers
    • Labels:
      None

      Description

      As described in the documentation (http://docs.doctrine-project.org/projects/doctrine-orm/en/latest/reference/events.html#preflush) my pre-flush lifecycle callback is not receiving an instance of Doctrine\ORM\Event\PreFlushEventArgs when called in Doctrine\ORM\Mapping\ClassMetadataInfo::invokeLifecycleCallbacks().

        Activity

        Kevin Herrera created issue -
        Fabio B. Silva made changes -
        Field Original Value New Value
        Assignee Benjamin Eberlei [ beberlei ] Fabio B. Silva [ fabio.bat.silva ]
        Fabio B. Silva added a comment -

        Hi Kevin,
        The current lifecycle event system does not allow access to the event args. :
        http://docs.doctrine-project.org/projects/doctrine-orm/en/latest/reference/events.html#lifecycle-callbacks.

        Now it is possible just by using the EventManager :
        http://docs.doctrine-project.org/projects/doctrine-orm/en/latest/reference/events.html#listening-to-lifecycle-events

        Just after DDC-1955 : (https://github.com/doctrine/doctrine2/pull/423) be merged it will be possible.

        Cheers

        Fabio B. Silva added a comment -

        Change issue type, since it's not a bug.

        Fabio B. Silva made changes -
        Issue Type Bug [ 1 ] Improvement [ 4 ]
        Fabio B. Silva made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.4 [ 10321 ]
        Resolution Fixed [ 1 ]

        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=DDC-2186, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Fabio B. Silva
            Reporter:
            Kevin Herrera
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: