Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-1948

Lazy Loading on Many To One association does not work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 2.1.7
    • Fix Version/s: None
    • Component/s: ORM
    • Security Level: All
    • Labels:
      None

      Description

      Create a many to one relationship with lazy loading as exposed there :
      http://stackoverflow.com/questions/7599007/lazy-loading-properties-not-loading-in-doctrine-2-0

      Notice that the relationship does not load while it should.

      The problem is always reproducible.

        Activity

        Hide
        Benjamin Eberlei added a comment -

        I need more information. The mapping of both entities, and a \Doctrine\Common\Utils\Debug::dump() of the $source entity when its a proxy. Also it would be helpful to have an SQL log which shows the queries executed by your example. Do you use any listeners?

        Show
        Benjamin Eberlei added a comment - I need more information. The mapping of both entities, and a \Doctrine\Common\Utils\Debug::dump() of the $source entity when its a proxy. Also it would be helpful to have an SQL log which shows the queries executed by your example. Do you use any listeners?
        Hide
        Marco Pivetta added a comment -

        Closing as incomplete.

        Please test this with latest master before eventually re-opening

        Show
        Marco Pivetta added a comment - Closing as incomplete. Please test this with latest master before eventually re-opening

          People

          • Assignee:
            Marco Pivetta
            Reporter:
            Julien AUBIN
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: