Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-1660

Annotation @version is not allowed to be declared on class

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2.1
    • Component/s: Mapping Drivers, ORM
    • Security Level: All
    • Labels:
      None

      Description

      I upgraded to Doctrine 2.2 and got following exception:

      "Doctrine\Common\Annotations\AnnotationException [Semantical Error] Annotation @version is not allowed to be declared on class SomeEntityClass. You may only use this annotation on these code elements: PROPERTY."

      In Doctrine 2.1 no such exception has been thrown. I use following annotation for all my classes in my projects:

      @version $Id: SomeEntityClass.php 509 2012-02-03 09:38:48Z mf $

      Thus I cannot upgrade to Doctrine 2.2 for now.

        Activity

          People

          • Assignee:
            Fabio B. Silva
            Reporter:
            Miroslav Fedeles
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: