Doctrine 2 - ORM
  1. Doctrine 2 - ORM
  2. DDC-1370

preInsert, postInsert, prePersist, postPersist, preUpdate, postUpdate code and documentation of events

    Details

    • Type: Improvement Improvement
    • Status: Awaiting Feedback
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 2.x
    • Component/s: ORM
    • Security Level: All
    • Labels:
      None

      Description

      Currently we have a set of Lifecycle events, but they seem to be misleading both in actual implementation and documentation.

      One good example is prePersist and postPersist, which is only fired when you're creating new entities. It should be renamed to preInsert and postInsert.
      As of preUpdate and postUpdate, they seem quite valid.

      But if we rename prePersist and postPersist to (pre|post)Insert, we may have a situation where you wanna cover both insert and update.
      For this, (pre|post)Persist should be reinstated, but acting differently from what it does currently.

        Activity

        Guilherme Blanco created issue -
        Guilherme Blanco made changes -
        Field Original Value New Value
        Fix Version/s 2.x [ 10090 ]
        Fix Version/s 2.2 [ 10157 ]
        Benjamin Eberlei made changes -
        Workflow jira [ 13007 ] jira-feedback [ 13965 ]
        Benjamin Eberlei made changes -
        Workflow jira-feedback [ 13965 ] jira-feedback2 [ 15829 ]
        Benjamin Eberlei made changes -
        Workflow jira-feedback2 [ 15829 ] jira-feedback3 [ 18085 ]
        Hugo Henrique made changes -
        Status Open [ 1 ] Awaiting Feedback [ 10000 ]

          People

          • Assignee:
            Benjamin Eberlei
            Reporter:
            Guilherme Blanco
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated: