Doctrine 1
  1. Doctrine 1
  2. DC-445

SQLite3 *does* support foreign keys

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.2.1
    • Fix Version/s: None
    • Component/s: Connection, Relations
    • Labels:
      None
    • Environment:
      SQLite 3

      Description

      SQLite3 from 3.6.19 does natively support foreign keys. Older versions do read and ignore foreign key declarations - and tools exist to read the schema from a sqlite3 db and create "foreign key triggers"

      Not including foreign key declarations in table DDL seems rather odd, if not a bug

      1. diff
        2 kB
        Hans-Peter Oeri

        Activity

        Jonathan H. Wage added a comment -

        I don't think we can add this to 1.2.2 because instantly turning on this support for people already using sqlite might break existing code. Moving it to 1.3 milestone.

        Jonathan H. Wage added a comment -

        The version 3.6.19 is pretty new, we should avoid version specific features. Maybe in the future once this version has established itself we can consider adding support for this. Anyways, sqlite is not really a recommended production rdbms.


          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            Hans-Peter Oeri
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: