Doctrine 1
  1. Doctrine 1
  2. DC-219

AuditLog does not generate relations in version table class (Doctrine 1.1 has that ability)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.2.0-BETA3
    • Fix Version/s: None
    • Component/s: Behaviors
    • Labels:
      None
    • Environment:
      Symfony 1.3-BETA2, Doctrine-1.2-BETA3, PHP 5.2.6, Mac OS X 10.6.2

      Description

      The Versionable behavior has the option 'generateRelations' and passes that on to the AuditLog.

      But there's a difference between the AuditLog in Doctrine 1.1 and Doctrine 1.2

      Here: http://trac.doctrine-project.org/browser/branches/1.1/lib/Doctrine/AuditLog.php?rev=5193 you can clearly see that relations are being generated in the version table class (L94:111) but this section is missing here: http://trac.doctrine-project.org/browser/branches/1.2/lib/Doctrine/AuditLog.php

      I copied that piece of code over to 1.2-BETA3 and it works flawlessly, does not look suspicious to me.

      Thanks for this great software!

        Activity

        Jonathan H. Wage added a comment -

        The functionality was removed due to many other problems caused by it in 1.1.

        florent BEAUCHAMP added a comment - - edited

        By the way, if this option is disabled, the versionning is useless if you don't use versionable with softdelete.

        With cascadeDelete option set to "true", each time you delete one of the record linked with the versionned one , all the versioning is lost
        Without, each time you try to delete one of the record linked with the versionned one, an exception about foreign key is raised


          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            Daniel Lohse
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: