Doctrine 1
  1. Doctrine 1
  2. DC-215

Invalid fix for DC-204, the clone should take over the hydration mode

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.2.0-BETA2
    • Fix Version/s: 1.2.0-BETA3
    • Component/s: Query
    • Labels:
      None

      Description

      The fix for DC-204 in changeset [6691] is incorrect. I have a model using the nested set plugin. When I set hydration mode HYDRATE_ARRAY on its base query and perform a query objects are returned instead of arrays. I think this is due to the fact that clones of the query should take over the selected hydration mode. Please have a look.

        Activity

        Dennis Verspuij added a comment -

        Duplicate of DC-223, now fixed


          People

          • Assignee:
            Guilherme Blanco
            Reporter:
            Dennis Verspuij
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: