Doctrine 1
  1. Doctrine 1
  2. DC-1031

CLONE -Multiple connections and i18n (raised as unresolved - original ticket marked as resolved)

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Blocker Blocker
    • Resolution: Unresolved
    • Affects Version/s: 1.2.2, 1.2.3
    • Fix Version/s: 1.2.3
    • Component/s: Connection, I18n
    • Labels:
      None
    • Environment:
      MySQL 5.1.37
      PHP 5.2.11
      symfony 1.2.11 DEV

      symfony 1.4.13
      PHP 5.3.6
      Postgres 8.4.8

      Description

      I used to work with a single database named "doctrine". The query was working properly.

      I then decided to use 2 databases so I got my schema like this:

      connection: doctrine

      Category:
      actAs:
      I18n:
      actAs:
      Sluggable:
      fields: [name]
      Timestampable: ~
      fields: [name, description]
      columns:
      id: ~
      name:
      type: string(255)
      notnull: true
      description: string

      User:
      connection: second
      columns:
      id: ~
      name:
      type: string(255)
      notnull: true

      I did setup my connections in config/databases.yml this way:

      all:
      doctrine:
      // ....
      second:
      // ....

      build-model, build-forms, build-filters and cc got ran. But now, I got an exception saying the "Translation" relation doesn't exist. The Base Models include correctly the bindComponent line:

      Doctrine_Manager::getInstance()->bindComponent('Category', 'doctrine');

      For now, I managed to kind of fixing it with simply swapping the databases order in my config/databases.yml and it's now working again perfectly.

      I forgot to mention that in the CategoryTable when i call $this->getConnection()->getName(), it outputs "second"

        Activity

        Hide
        Andy.L added a comment -

        meet the same issue and it really blocked my project, seems no one will maintain 1.x. I'm considering whether to replace symfony 1.4 with 2.0.

        Show
        Andy.L added a comment - meet the same issue and it really blocked my project, seems no one will maintain 1.x. I'm considering whether to replace symfony 1.4 with 2.0.
        Hide
        James Bell added a comment -

        Original issue: DC-363 (http://www.doctrine-project.org/jira/browse/DC-363)

        There are some additional comments in there that explain the issue as currently being seen in released versions of Doctrine 1.2. Can I help verify that this is the same ticket?

        What is needed to help with debug (in addition to the extra information already provided)?

        Show
        James Bell added a comment - Original issue: DC-363 ( http://www.doctrine-project.org/jira/browse/DC-363 ) There are some additional comments in there that explain the issue as currently being seen in released versions of Doctrine 1.2. Can I help verify that this is the same ticket? What is needed to help with debug (in addition to the extra information already provided)?

          People

          • Assignee:
            Jonathan H. Wage
            Reporter:
            James Bell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: