Doctrine DBAL
  1. Doctrine DBAL
  2. DBAL-85

Illegal quotes in SHOW FULL TABLES WHERE Table_type = "BASE TABLE"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.2
    • Component/s: Platforms
    • Labels:
      None

      Description

      When trying to generate update SQL on MySQL running in ANSI SQL mode you get the error:
      SQLSTATE[42S22]: Column not found: 1054 Unknown column 'BASE TABLE' in 'where clause'

      This is caused by the use of identifier quotes (") instead of literal quotes (') in the query
      SHOW FULL TABLES WHERE Table_type = "BASE TABLE"

      This is in MySqlPlatform#getListTablesSQL()

        Issue Links

          Activity

          Bernhard Schlas added a comment -

          Here is a temporary dirty patch for this problem. ONLY FOR TESTING PURPOSE!!!

          Karsten Dambekalns added a comment -

          Why not simply change MySqlPlatform#getListTablesSQL()?

          Bernhard Schlas added a comment -

          Because did this quick and dirty patch before i read this issue. Actually i've attached a better one,

          Karsten Dambekalns added a comment -

          With this change it works for me.

          Benjamin Eberlei added a comment -

          Fixed.


            People

            • Assignee:
              Benjamin Eberlei
              Reporter:
              Karsten Dambekalns
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: