Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Can't Fix
    • Affects Version/s: 2.0.0-BETA4, 2.0, 2.0.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      mysql 5.1.49 for debian-linux-gnu (x86_64), Ubuntu 10.10 Doctrine DBAL Beta4 Doctrine ORM Beta4 Doctrine Common RC1

      Description

      class product {
      /**
      *Column(type="decimal", scale="2")
      *
      */
      private $discount;
      }

      generate SQL

      create table product {
      discount DECIMAL(10,2) NOT NULL
      }

      if you have a field in a database type DECIMAL doctrine tries to
      generate for him diff

      doctrine orm:schema-tool
      >
      ALTER TABLE product CHANGE discrount discrount NUMERIC (10, 2) NOT NULL

      but mysql ignore the alter, as a result of these diff stretch from
      migration to migration

        Activity

        Eugene created issue -
        Benjamin Eberlei added a comment -

        This is fixed in RC1 or RC2.

        Benjamin Eberlei made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Eugene added a comment -

        checked for the version of doctrine 2.1.0-DEV
        result is the same

        Eugene made changes -
        Resolution Duplicate [ 3 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Eugene made changes -
        Comment [ checked for the version of doctrine 2.1.0-DEV
        result is the same
        ]
        Oleg Anashkin added a comment -

        I have the same issue with the latest doctrine build. Please fix it because it makes schema migration scripts dirty with redundant changes.

        Oleg Anashkin made changes -
        Affects Version/s 2.0.1 [ 10115 ]
        Affects Version/s 2.0 [ 10067 ]
        Benjamin Eberlei added a comment -

        I cannot reproduce this, does this happen if you also specify precision=10 ?

        Alexander added a comment -

        Closing until someone can provide more feedback.

        Alexander made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Can't Fix [ 7 ]
        Benjamin Eberlei made changes -
        Workflow jira [ 12226 ] jira-feedback2 [ 17847 ]
        Benjamin Eberlei made changes -
        Workflow jira-feedback2 [ 17847 ] jira-feedback3 [ 20202 ]
        Joel Simpson added a comment -

        I am seeing this bug for a definition specified as:

        • @ORM\Column(type="decimal", precision=20, scale=0, nullable=false, unique=true)

        Doctrine Command Line Interface version 2.3.2-DEV


        This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

        • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=DBAL-77, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

          People

          • Assignee:
            Benjamin Eberlei
            Reporter:
            Eugene
          • Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: