Doctrine DBAL
  1. Doctrine DBAL
  2. DBAL-53

Missing convertToDatabase-calls when loading and persisting entities

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      As we use binary encoded UUIDs as primary keys, we sometimes stumbled upon the issue of having incorrect SQL queries executed with unencoded database values. Currently we observed the wrong behavior for the following scenarios:

      • Deleting entities
      • OneToOne relations
      • OneToMany relations

      I'm pretty sure this bug also exists for OneToMany relations, but we haven't used them yet.

        Issue Links

          Activity

          Lars Strojny created issue -
          Benjamin Eberlei added a comment -

          Duplicate of DBAL-15

          Benjamin Eberlei made changes -
          Field Original Value New Value
          Link This issue duplicates DBAL-15 [ DBAL-15 ]
          Benjamin Eberlei made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Benjamin Eberlei made changes -
          Workflow jira [ 11926 ] jira-feedback2 [ 17666 ]
          Benjamin Eberlei made changes -
          Workflow jira-feedback2 [ 17666 ] jira-feedback3 [ 20021 ]

          This list may be incomplete, as errors occurred whilst retrieving source from linked applications:

          • Request to http://www.doctrine-project.org/fisheye/ failed: Error in remote call to 'FishEye 0 (http://www.doctrine-project.org/fisheye/)' (http://www.doctrine-project.org/fisheye) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=DBAL-53, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 503 (Service Temporarily Unavailable)

            People

            • Assignee:
              Benjamin Eberlei
              Reporter:
              Lars Strojny
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: