Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The API could be improved in the next major release:

      • Type::add() instead of addType()
      • Type::isRegistered() instead of hasType() (has sounds weird)

      Etc.. I think the 'type' in the methods is redundant since Type is already the object I am dealing with.

      I'd also like a remove() method to unregister a type at runtime. Would make testing a little easier and I don't have to check with hasType() etc..

        Activity

          People

          • Assignee:
            Benjamin Eberlei
            Reporter:
            Till
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated: